Cara Konfigurasi VLAN dengan Switch Layer 3

Penggunaan VLAN bertujuan untuk membagi broadcast domain di lingkungan LAN. Pada saat host dalam satu VLAN berkomunikasi dengan host di VLAN lain, maka diperlukan router supaya VLAN satu dengan VLAN lain dapat terkoneksi. Router bekerja pada layer 3 yaitu layer Network, maka dari itu switch layer 3 berarti juga berfungsi sebagai router. Pada postingan ini saya menggunakan Cisco Switch Catalyst 3560 24PS.


Saya beri contoh topologinya seperti ini :


Desain Jaringan :

Pada tutorial ini Saya membuat jaringan yang terbagi menjadi 3 VLAN yaitu Blok A, Blok B, dan Blok C. Berikut ini perinciannya :

  1. VLAN 10 dengan nama Blok A
    Dengan 3 komputer yang terhubung ke switch Blok A port fast Ethernet 0/1, 0/2, dan 0/3
    IP Address komputer masing-masing 192.168.1.1, 192.168.1.2, dan 192.168.1.3
    Subnet Mask : 255.255.255.0 gateway 192.168.1.254
  2. VLAN 20 dengan nama Blok B
    Dengan 3 komputer yang terhubung ke switch Blok B pada port fast Ethernet 0/1, 0/2, dan 0/3
    IP Address komputer masing-masing 192.168.2.1, 192.168.2.2, dan 192.168.2.3
    Subnet Mask : 255.255.255.0 gateway 192.168.2.254
  3. VLAN 30 dengan nama Blok C
    Dengan 3 komputer yang terhubung ke switch Blok C port fast Ethernet 0/1, 0/2, dan 0/3
    IP Address komputer masing-masing 192.168.3.1, 192.168.3.2, dan 192.168.3.3
    Subnet Mask : 255.255.255.0 gateway 192.168.3.254
Berikut ini Langkah-Langkah Pembuatan VLAN :

A. Langkah Awal
  1. Buatlah topologinya seperti gambar diatas.
  2. Berikan IP Address, Subnet mask, dan Gateway pada masing-masing komputer sesuai dengan data diatas.
B.  Konfigurasi VLAN
  1. Buat VLAN 10 (Blok A), VLAN 20 (Blok B), dan VLAN 30 (Blok C)
    Switch>en
    Switch#conf t
    Switch(config)#vlan 10
    Switch(config-vlan)#name Blok-A
    Switch(config-vlan)#exit
    Switch(config)#VLAN 20
    Switch(config-vlan)#name Blok-B
    Switch(config-vlan)#exit
    Switch(config)#VLAN 30
    Switch(config-vlan)#name Blok-C
    Switch(config-vlan)#exit
  2. Berikan IP Address pada masing-masing VLAN (Sebagai Gateway)
    Switch(config)#interface vlan 10
    Switch(config-if)#ip address 192.168.1.254 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#interface vlan 20
    Switch(config-if)#ip address 192.168.2.254 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#interface vlan 30
    Switch(config-if)#ip address 192.168.3.254 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
  3. Ubah port Fast Ethernet 0/1 menjadi akses VLAN 10, 0/2 menjadi akses VLAN 20, dan 0/3 menjadi akses VLAN 30
    Switch(config)#interface FastEthernet 0/1
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet 0/2
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet 0/3
    Switch(config-if)#switchport access vlan 30
    Switch(config-if)#end
C. Langkah Akhir
  1. Test Ping dari Switch ke masing masing komputer, jika berhasil maka hasilnya seperti ini :
    Switch#ping 192.168.1.1

    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    .!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 7/8/10 ms

    Switch#ping 192.168.2.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
    .!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 8/9/11 ms

    Switch#ping 192.168.3.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
    .!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 6/8/9 ms
  2. Jika sudah berhasil, simpan konfigurasi.
    Switch#write memory
    Building configuration...
    [OK]
  3. Anda juga bisa coba ping dari komputer Blok A ke Blok C.
    PC>ping 192.168.3.1

    Pinging 192.168.3.1 with 32 bytes of data:

    Reply from 192.168.3.1: bytes=32 time=16ms TTL=127
    Reply from 192.168.3.1: bytes=32 time=16ms TTL=127
    Reply from 192.168.3.1: bytes=32 time=17ms TTL=127
    Reply from 192.168.3.1: bytes=32 time=17ms TTL=127

    Ping statistics for 192.168.3.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 16ms, Maximum = 17ms, Average = 16ms

Sekian tutorial dari saya, bila ada masukan atau pertannyaan mohon isikan pada kotak komentar.



Baca Juga :
  1. Mengenal Home Automation System (Rumah Pintar)
  2. Cara Cepat dan Mudah Belajar Mengetik dengan 10 Jari
  3. Penyebab Komputer Berjalan Lambat

16 Responses to "Cara Konfigurasi VLAN dengan Switch Layer 3"

  1. pak boleh tanya, aku masih bingung dengan topologi di atas, sudah saya coba tapi blum bisa
    aku punya modem dg ip 192.168.1.1, lalu aku punya 3com layer 3 dg ip 192.168.1.105, lalu aku punya procurve layer 2 dengan ip 192.168.1.101, trus ada komputer1 dg ip 192.168.1.7 dan komputer2 dg ip 192.168.2.10,
    aku sudah seting vlan di switchlayer3 port 8 dg ip 192.168.2.1, lalu kabel data dari procurve saya koneksi ke port 8 dari 3com, tapi komputer dg ip 192.168.2.10 tidak bisa koneksi ke internet.
    pertanyaannya:
    1. di procurve saya harus seting apa
    2. di komputer saya harus seting apa
    3. lalu di switchlayer3 sendiri saya harus seting apa

    makasih pak atas jawabannya
    saptadi2003@yahoo.com

    ReplyDelete
  2. Berikut ini penjelasan tentang topologi diatas :
    Pada switch layer3 terdapat 3 port yang aktif, yaitu FastEthernet 0/1(fa0/1) , fa0/2, dan fa0/3.

    fa0/1 disetting sbg vlan 10 IP Add 192.168.1.254
    fa0/2 disetting sbg vlan 20 IP Add 192.168.2.254
    fa0/3 disetting sbg vlan 30 IP Add 192.168.3.254

    Terdapat 9 PC yang terbagi menjadi 3 subnet dan/ vlan :

    [VLAN 10] PC 1-3 IP 192.168.1.1 s/d 192.168.1.3 gateway 192.168.1.254
    [VlAN 20] PC 3-6 IP 192.168.2.1 s/d 192.168.2.3 gateway 192.168.2.254
    [VLAN 30] PC 7-9 IP 192.168.3.1 s/d 192.168.3.3 gateway 192.168.3.254

    Maaf untuk 3 pertanyaan bapak diatas saya belum jelas karena topologinya saya belum mengerti. kemudian saya belum mengerti perintah2 yang digunakan untuk setting VLAN pada switch selain cisco.

    Terima Kasih

    ReplyDelete
  3. mas punya konfigurasi bila kita ingin menghubungkan 2 topologi diatas?

    ReplyDelete
  4. makasih banyak gan tutorialnya ini sangat bermanfaat buat saya .

    ReplyDelete
  5. Terimakasih gan penjelasan juga konfigurasi dalam artikelnya

    pluss gambarnya maknyus

    moga bertambah ilmunya dan manfaat

    ReplyDelete
  6. Untuk Mas Jordan :
    Jika ingin menghubungkan 2 topologi diatas maka diperlukan konfigurasi VLAN TRUNKING, tapi maaf mas saya belum berhasil mencobanya. Mungkin mas bisa mencoba mencarinya disitus lain dengan keyword konfigurasi vlan trunking.

    Untuk yang lainnya terima kasih juga ya...

    ReplyDelete
  7. maaf mas . .
    saya sudah ikuti langkah2 seperti pada tutorial tersebut, tetapi waktu hasil akhir, saat saya meng-ping komputer dengan switch ke komputer 192.168.1.1 bisa, tetapi ke komputer 192.168.2.1 dan 3.1 tidak bisa mas ???

    bagaimana cara mengatasinya ?

    andimarioj@gmail.com

    ReplyDelete
  8. Jika mas andi sudah berhasil ping ke Vlan 10 dgn ip 192.168.1.1 dari switch layer 3, seharusnya ping ke vlan 20 dan 30 berhasil juga. karena antara switch layer 3 dengan komputer2 diatas masih satu subnet (Network ID-nya sama).

    Mungkin mas bisa periksa lagi / setting dari ulang. terima kasih.

    ReplyDelete
  9. "Mas saya mau tanya,,,
    ada 1 switch dan 3VLan, masing-masing VLan memiliki 3pc dan masing-masing VLan memiliki subnet mask yag berbeda,,,
    nah bagaimana cara konfigurasi agar seluruh VLan bisa conect / ping da sapat Telnet Switchnya,,,

    Atas bantuannya terimakasih ^_^,,,"

    ReplyDelete
    Replies
    1. Jika switch yg kamu gunakan bukan switch layer 3. maka diperlukan router supaya 3 vlan tsb bisa saling berkomunikasi.

      Jika switchnya cisco layer 3, cara konfigurasinya sama seperti tutorial diatas, tinggal diganti ip address dan subnet masknya saja.

      Terima Kasih

      Delete
  10. mikum maaf mas saya pengen belajar configuration sayaa benar benar dari tolong bantu ajarin ya mas mau kursus modalnya ga dajadi saya pengn belajar.tolong ya

    ReplyDelete
    Replies
    1. Iya emang gak perlu kursus kok, yg penting mau belajar. Bahan materi dan tutorialnya juga banyak dan gratis di internet. triknya kuasai istilah2 dasar secara detail dulu, misalnya ip address, gateway, netmask itu apa dan bagaimana.

      bahan materi yg cukup lengkap salah satunya dari ilmukomputer.org di alamat http://ilmukomputer.org/category/jaringan-komputer/

      terima kasih

      Delete
  11. misi mas mau nanya
    itu konfigurasinya hanya di switch 3560 atau di semua switch mas?

    ReplyDelete
  12. @ Mas Syahrul:

    kalau command2-nya hanya untuk tipe2 managed switch merk cisco. paling2 ada sedikit berbeda jika versi ios-nya beda

    ReplyDelete
  13. mas Agus, saya masih bingung. utk Fa0/4 itu maksudnya kalau dalam satu switch ada 3 port yg digunakan yg dihubungkan ke masing2 gateway networknya ya?

    ReplyDelete